GAミント至上主義

コストにうるさいWEBアプリ開発者。最近はPython, Vue.js, Kubernetesがメイン@株式会社ビズオーシャン。https://github.com/uyamazak/

GKEでKubernetes 1.8が使えるようになったのでCron Jobsを使う

cron的なバッチ処理をKubernetesで行えるCron Jobsが1.8から使えるようになって、ちょうど他のメンバーの新規プロジェクトで必要になったので使ってもらった。


kubernetes.io

Prerequisites
You need a working Kubernetes cluster at version >= 1.8 (for CronJob). 


gcloudのkubectlも11/1時点ではまだ1.7だったけど、11/2でupdateをかけたら1.8になった。